Adding new users in librenms


I have deployed librenms in Docker, I want to give new users access to the librenms GUI, how can I do that?
I tried this command “docker-compose exec --user librenms librenms php adduser.php 10 ” but i did not get any new user on the GUI

Thank you so much.

Can’t you just go to: https://YOUR.LIBRE.NMS/users and add the user there?

No i can delete users, or change permission but i dont have the possibility to add and Im admin.

Please show us a screenshot of https://YOUR.LIBRE.NMS/users so we can see if you really can’t add new users

It should looks like that :
Parameters → Manage Users → Add User

1 Like

I dont see any button Add user…

Use this command in the librenms container (it worker for me) :

php artisan user:add username

Source : Can't create users - #3 by WRMSR

Im using active directory authentication so the command works but the user won’t be able to connect be cause the command use MySQL auth

I found out that the server is connected with auto adding users from the active directory but users dont have access and the error is Invalid credentials.

1 Like

Wait, how did you added other users if the “Add user” button is not showing in your LibreNMS GUI ?

If you have LDAP auth then you do not able to add user via LibreNMS, you must add in AD.

I have similar problem. Colleague that was managing LibreNMS quit with the end of January, and I continued to do his work. He didn’t elevate rights for my user to admin level, and now I can’t add or remove users, nor do I have option to do so in my GUI.

He told me to use adduser.php tool on Linux, and when I do it says that user that I wanted to add was added successfully but I can’t log in with it to GUI. It says invalid credentials.

Command that I use looks like this: ./adduser.php username, password, level 1-10, email without commas ofcourse

Any suggestions on what I’m doing wrong? I have been trying to do this for 2 days already and nothing seems to be working.

You should maybe ask him to come and create an admin account for you

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.