Ajax_table.php throwing error

Steps to reproduce:

  1. Open ARP Table
  2. Check errors from Chrome Dev Console


1 Like

have the exact same issue, unsure when it first started


Having the same problem here, not sure when it started.

Version 1.66-30-g13e0da2f0 - Mon Aug 17 2020 07:27:07 GMT-0400
Database Schema 2020_07_29_143221_add_device_perf_index (172)
Web Server Apache/2.4.29 (Ubuntu)
PHP 7.2.32-1+ubuntu18.04.1+deb.sury.org+1
Python 3.6.9
MySQL 10.1.44-MariaDB-0ubuntu0.18.04.1
Laravel 7.19.0
RRDtool 1.7.0

I had the same problem with ARP table.

removed “?int” from line 60 in /opt/librenms/LibreNMS/Cache/Device.php
“public function get(?int $device_id) : \App\Models\Device”

I know it’s not the right fix but i needed this to work “asap” :wink:

This also worked for me … even if don’t now what this change actually does :smiley: Thx

Looks like it might of broke after https://github.com/librenms/librenms/pull/11975, as that was on 7/31, and added the changes you removed to fix the issue.

1 Like

Fixed by; https://github.com/librenms/librenms/pull/12075

1 Like

I made this change locally but still got same error.

do I need to somehow flush the cache?

I’ve tested on 2 different systems, both work.
whats the output of git diff after you apply the patch?
also, could you post the whole error in that case?

you are right, doing ./scripts/github-apply 12075 helped