Auto Discover CDP/LLDP - ' ' is not valid hostname

I am having issues with CDP and LLDP Discovery with a Cisco Catalyst 6506. I am running LibreNMS on the latest docker container version. Not sure how to reproduce the issue, though I have tried removing the device and re-adding it. This is happening to multiple devices on my network though.

Here is my output of ./validate.php

Component | Version
--------- | -------
LibreNMS  | 1.62.2
DB Schema | 2020_03_24_0844_add_primary_key_to_device_graphs (160)
PHP       | 7.3.14
MySQL     | 10.2.30-MariaDB-1:10.2.30+maria~bionic
RRDTool   | 1.7.2
SNMP      | NET-SNMP 5.8

[OK]    Installed from the official Docker image; no Composer required
[OK]    Database connection successful
[OK]    Database schema correct
[WARN]  IPv6 is disabled on your server, you will not be able to add IPv6 devices.
[WARN]  Updates are managed through the official Docker image

My paste of ./discovery.php -h 185 -m discovery-protocols -d is below.

Please let me know if you have any ideas to fix this issue!


The doc is describing this :

Discovering devices by IP

By default we don’t add devices by IP address, we look for a reverse dns name to be found and add with that. If this fails and you would like to still add devices automatically then you will need to set $config['discovery_by_ip'] = true;


Thanks, though our problem still exists. I am trying to get the neighbors tab of that device to show the network devices attached to it. I tried adding that config option but it still will not show the neighbors tab.

Then please provide again the discovery-protocols logs, if something is wrong, you’ll see it there.

I think I figured it out. For some reason the docker image was having an issue discovering the neighbors of the device but as soon as I swapped off of docker to a normal install it had no issues.