Cambium PTP600/PTP800 Generic Since 12/2017 Update

Ever since the “Cambium Refactor” on 6 December (see LibreNMS notification sent on 28 November 2017), all 30 of my Cambium point-to-point wireless bridges were automatically recategorized as ‘server’ devices with ‘generic device’ operating systems. Most of the radios are PTP600 of one variation or another (49600 and 58600), and a couple of them are PTP800. Prior to the update, they were correctly recognized as Cambium wireless devices, complete with the Cambium logo appearing next to them.

Is it possible that the PTP600 and PTP800 were overlooked in the associated code? I’m not certain where to look, but my greps so far are not turning up any instances of either of those models.

Looks like support is being worked on

Also please validate your install and post the output.

Thanks, Kevin, I appreciate the relevant link.

Here’s the validation output:
$ ./validate.php
Component | Version
--------- | -------
LibreNMS | 1.33-308-g4fc946b
DB Schema | 227
PHP | 7.0.22-0ubuntu0.16.04.1
MySQL | 5.7.20-0ubuntu0.16.04.1
RRDTool | 1.5.5

[OK]    Database connection successful
[OK]    Database schema correct

Please test the pull request to see if it fixes it for you.

Ok, I successfully did a github-apply on PR 7998. Waited a little, also tried rediscovering one of the devices, but no change. I did note that the pull request only seems to cover PTP300s and PTP500s at this point, which doesn’t apply to the models I have here.

Thanks a lot to both of you, laf and Kevin, for the speedy replies!