Cannot access WebUI

I’m having an issue with my LibreNMS instance - The biggest issue is that I didn’t set it up and I know nothing about it at all, aside from the root PW.

That being said, I can’t access the webUI on any browser (latest Chrome, FF). I keep getting the message:

Error: bootstrap/cache, storage, storage/framework/sessions, storage/framework/views, storage/framework/cache not writable! Run these commands as root on your LibreNMS server to fix:

chown -R librenms:librenms /opt/librenms/bootstrap/cache /opt/librenms/storage /opt/librenms/storage/framework/sessions /opt/librenms/storage/framework/views /opt/librenms/storage/framework/cache

setfacl -R -m g::rwx /opt/librenms/bootstrap/cache /opt/librenms/storage /opt/librenms/storage/framework/sessions /opt/librenms/storage/framework/views /opt/librenms/storage/framework/cache

setfacl -d -m g::rwx /opt/librenms/bootstrap/cache /opt/librenms/storage /opt/librenms/storage/framework/sessions /opt/librenms/storage/framework/views /opt/librenms/storage/framework/cache

I upgrade the system it’s running on (yum update), rebooted, then I ran all of those, commands. Rebooted and still isn’t working.

I ran ./validate.php and got the following.

Component Version
LibreNMS 1.39-65-g0448c9e
DB Schema 250
PHP 7.0.30
MySQL 5.5.56-MariaDB
RRDTool 1.4.8

[OK] Composer Version: 1.6.5
[OK] Dependencies up-to-date.
[OK] Database connection successful
[FAIL] Database: missing column (users/updated_at)
[FAIL] Database: missing column (users/remember_token)
[FAIL] We have detected that your database schema may be wrong, please report the following to us on IRC or the community site (
[FIX] Run the following SQL statements to fix.
SQL Statements:
ALTER TABLE users ADD remember_token varchar(100) NULL AFTER updated_at;
[WARN] Some devices have not been polled in the last 5 minutes. You may have performance issues.
[FIX] Check your poll log and see:

I’m a little hesitant to run random things in the event something breaks because like I said, I didn’t set it up and the guy who did doesn’t work here anymore (and isn’t giving a lot of assistance). It’s running on a CentOS 7

run the commands its asking you to do.

We found many users needed to update their selinux contexts.

1 Like

I did. (I said I did up there also heh)

The docs have different commands to the ones you tried, try the ones in those linked docs.

also paste output of sestatus command

Ok I see…

SELinux status: enabled
SELinuxfs mount: /sys/fs/selinux
SELinux root directory: /etc/selinux
Loaded policy name: targeted
Current mode: enforcing
Mode from config file: enforcing
Policy MLS status: enabled
Policy deny_unknown status: allowed
Max kernel policy version: 31
You have mail in /var/spool/mail/root

you will need to run the commands in murrant’s post

see Recommended permissions fixes are ignored [Solved]

Fixed for me. Not sure what happened - It was working fine, then came in one day and couldn’t access.

Yeah they did an update that broke it for a bunch of people (me included lol).

1 Like

It was intentional, as we added some new capabilities. Was hoping the messages displayed in the web browser would be enough, but we found many people needed mbstring and have odd issues with their installs (like multiple PHP versions).

See the notice for the upcoming stable release New Requirements for 1.40

1 Like