Cannot Ping Fortigate Firewall

Tags: #<Tag:0x00007f3b89888ff8>

I recently upgraded Python to version 3.6, and PHP to version 7.4. Since then, LibreNMS has been unable to reach a Fortigate firewall, which it previously had no trouble reaching. How can I troubleshoot?

[[email protected] librenms]# ./validate.php
====================================
Component | Version
--------- | -------
LibreNMS  | 1.63-147-g46fa4ea
DB Schema | 2020_04_06_001048_the_great_index_rename (165)
PHP       | 7.4.6
Python    | 3.6.8
MySQL     | 5.5.65-MariaDB
RRDTool   | 1.4.8
SNMP      | NET-SNMP 5.7.2
====================================

[OK]    Composer Version: 1.10.6
[OK]    Dependencies up-to-date.
[OK]    Database connection successful
[OK]    Database schema correct
[WARN]  Your local git contains modified files, this could prevent automatic updates.
        [FIX]:
        You can fix this with ./scripts/github-remove
        Modified Files:
         storage/framework/views/.gitignore

./discovery.php -h 192.168.254.100 -d | ./pbin.sh: https://p.libren.ms/view/775bf087
./poller.php -h 192.168.254.100 -r -f -d | ./pbin.sh: https://p.libren.ms/view/87022df3

[[email protected] librenms]# sestatus
SELinux status:                 enabled
SELinuxfs mount:                /sys/fs/selinux
SELinux root directory:         /etc/selinux
Loaded policy name:             targeted
Current mode:                   permissive
Mode from config file:          permissive
Policy MLS status:              enabled
Policy deny_unknown status:     allowed
Max kernel policy version:      31
[[email protected] librenms]# fping -e -q -c 3 -p 500 -t 500 192.168.254.100
192.168.254.100 : xmt/rcv/%loss = 3/3/0%, min/avg/max = 0.37/0.40/0.46

snmpwalk -v2c -c community 192.168.254.100 works as expected.

Thank you.

Could be possible that you used the Overwritte IP as comment?

Is about this Assigned IP: Corporate Firewall

1 Like

Thank you for your prompt response! I cleared that field and attempted to rediscover. The device status changed back to “Up” and I’m hopeful the problem is resolved. I’ll mark your reply as the solution if I see that all is well.