Change IP of LibreNMS server, Now portions do not work

Hello all, I recently moved our Librenms Server to a different site on our site to site tunnel. Currently the Ip for Libre was 10.0.0.176. At our new site it is now 152.168.34.176 . Libre is working but when i try to delete a device it attempts to got to 10.0.0.176 (http://10.0.0.176/delhost/) and then gives an error web page . How can i change the old ip on 10.0.0.176 to 152.168.34.176 so all works as normal again.

Check config.php for $config['base_url'] and also run lnms config:get base_url.

Update config.php to remove that base_url value and set it with lnms config:set base_url NEWVALUE

A better option if the server address can change or has multiple aliases is to just set base URL to /

Our installation was originally set up with a full hostname as the base URL (in global settings, system, server, “specific URL”) and that worked fine however when I wanted to access it via a VPN without passthrough DNS I could not access it by IP address as all the page links were relative to that base path, so it would try to redirect to the hostname which the client could not resolve.

However with the base path just set to a forward slash I can now access LibreNMS equally well via hostname or IP address and it stays with whichever address I use to connect to it following page clicks.

So unless there is a good reason to I would always just use / as a relative basepath and control access to which interface/hostnames it can be accessed on via the apache/nginx configuration.