Checking "Disable polling and alerting" for a service check still generates alerts

Create a service check and check “Disable polling and alerting”. I still receive alerts and apperently the check is still being checked.

If i then check the “Ignore alert tag” I also still get alerts.

I do not understand why nothing is (apparently) happening when clicking either of the two.

Component | Version
--------- | -------
LibreNMS  | 21.11.0-7-g7e98e0333
DB Schema | 2021_11_12_123037_change_cpwVcID_to_unsignedInteger (225)
PHP       | 7.4.3
Python    | 3.8.10
MySQL     | 10.3.31-MariaDB-0ubuntu0.20.04.1
RRDTool   | 1.7.2
SNMP      | NET-SNMP 5.8

[OK]    Composer Version: 2.1.12
[OK]    Dependencies up-to-date.
[OK]    Database connection successful
[OK]    Database schema correct

Okay, so adding “AND services.service_ignore != 1” to the alert rule seems to suppress alerts when checking “Ignore alert tag” for a service.

However I still do not understand whan “Disable polling and alerting” is supposed to do.

@sman-dk you need two parts for it to work. Enable/disable that check box and check for it in your alert rule. The alert rules included in the alert rule collection respect the checkbox, so this must be a rule you created.

@murrant Which checkbox are you talking about? “Ignore alert tag”? How do I verify if the existing alert rules check for the alert tag?

With regards to the checkbox “Disable polling and alerting”, then polling is not disable by selecting this checkbox. What would be the expected behavior when selecting this checkbox?


That relates to services.service_disabled

@murrant Thank you for helping out. Do you think you could elaborate a bit in order to give an overview of what the two check boxes individually do, and how I verify this in the alert rules? Your answer is a bit too short for me to understand what you mean.

The checkboxes set one of two flags on the service.

In order for alerting to respect those flags, you need to add a check for the flags.

@murrant Thank you for pointing that out. I must admit that I find it confusing that this is not the default in the alert rules and I was unable to find it described in the documentation. But now I know how fix it in the alert rules. Thank you for your help! :slight_smile:

Have a great day!

Yeah, I noticed it is not in the default rule, which is pretty stupid. Hopefully, someone can update that.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.