Cisco Vpdn


Did anyone manage to get VPDN tab working in LibreNMS?

I’ve put the following at the bottom of my config file, but nothing has appeared for me on the device which is iosxe.

$config[‘os’][‘iosxe’][‘poller_modules’][‘cisco-vpdn’] = 1;

Any ideas?


after you enabled that did you try re-discovering the device?

Also, you shouldn’t have to add that into your config.php you can enable in the web UI for that device under settings → Modules

1 Like

Hi Chas,

Did you end up getting this working? I’m having the same issue, cisco 7200 type LNS and I need to track data. It worked fine on Observ… (i’ll refrain) but I’m super keen to get it sorted out on Libre

Sorry i’m afraid i haven’t tried again, we’re no longer using Cisco VPDN

Just to give this a little more attention, we’re doing the same as @ojexii; we’ve enabled the relevant switches on the devices in question, rediscovered, but nada.

Would/should this VPN tab show up on the Overview line as its own element, or within the graphs tab?