Continual alerts even when acknowledged

Running LibreNMS on Ubuntu Server 14.04.5 LTS. PHP7.1 and have successfuly run to update to current version. The “validate config” tool also comes back clear (apart from the PHP notification and a message about discovery not running as we dont use it)

We have had an issue since moving to PHP7.1 where we keep getting repeated email alerts, even when the alert has been acked. e.g. we have a couple of file servers that were running low on space a few days ago and we acked the alerts on the dashboard but we still have several hundred alerts emails and growing with “Disk space usage over 95 percent got acknowledged”.

Any ideas how I can resolve this? Im assuming some part of PHP is not working correctly after the 7.1 upgrade.

first discovery still needs to run, in order to discover any changes to your devices you should really fix that.
The auto-discovery is part of a module and that can be disabled.

Also, reason, why your alert keeps unmuting, is that the alert is still active.

see here -

I would Adjust the alert rule change the “Max” from -1 to 1

I think I have it fixed. I ran the /opt/librenms/validate.php rather than the gui validate tool and it flagged up a lot of missing PHP extensions and also the php timezone config.

Fixed all those and alerts now seem to be back to normal :slight_smile:

1 Like

Some OS have separate configs for CLI and FPM/Apache PHP.