Daily.sh not upgrading

Dear All,
What a great place is this to be!
I have been wondering for the past few days because I want to upgrade the version of librenms but daily.sh is not doing anything except:
Updating SQL-Schema OK
Cleaning up DB OK
output form the log from daily.sh
cat daily.log
Updating SQL-Schema
Nothing to migrate.
Returned: 0
Cleaning up DB
Refreshing alert rules queries
Clearing OS cache
Refreshing device group table relationships
Syslog cleared for entries over 30 days (about 0 rows)
Eventlog cleared for entries over 30 days
Perf times cleared for entries over 30 days
Device perf cleared for entries over 7 days
Deleting alert_logs more than 365 days that are not active
Deleting history of active alert_logs more than 365 days
Ports fdb cleared for entries over 10 days
Returned: 0
Updating SQL-Schema

output of ./validate.php

Component Version
LibreNMS 1.69-1-gbc02ab3f6
DB Schema 2020_10_21_124101_allow_nullable_ospf_columns (188)
PHP 7.4.3
Python 3.8.5
MySQL 10.3.29-MariaDB-0ubuntu0.20.04.1
RRDTool 1.7.2


[OK] Composer Version: 2.0.14
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct

run php artisan tinker inside librenms folder

use LibreNMS\Config;

It actually worked when
I put $config[‘update’] = 1; instead of #$config[‘update’] = 0;
So when its commented with =0 it still not going to update atleast in my case.
Now its all good - thanks for the suggestions. What is this file ‘php artisan tinker’ because I am unable to find it in Librenms Folder .
Wish you all the best!

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.