Daily.sh only checks database


since about a week my LibreNMS install stopped updating itself. the cronjob for daily.sh is running, but it seems to be only updating sql-schema.

daily.sh output:

Re-running /opt/librenms/librenms/daily.sh as librenms user
Updating SQL-Schema                                OK
Cleaning up DB                                     OK

validate.php output:

Component | Version
--------- | -------
LibreNMS  | 1.52-70-gf3ba8947f
DB Schema | 2019_05_30_225937_device_groups_rewrite (135)
PHP       | 7.2.19-0ubuntu0.18.04.1
MySQL     | 10.1.40-MariaDB-0ubuntu0.18.04.1
RRDTool   | 1.7.0
SNMP      | NET-SNMP 5.7.3

[OK]    Composer Version: 1.8.6
[OK]    Dependencies up-to-date.
[OK]    Database connection successful
[OK]    Database schema correct
[WARN]  Your install is over 24 hours out of date, last update: Sun, 23 Jun 2019 05:29:12 +0000
	Make sure your daily.sh cron is running and run ./daily.sh by hand to see if there are any errors.

I managed to track the problem to validate.php exiting on line 29, ie:

if ($options['f'] === 'update') {
    if (!Config::get('base_url')) {
        exit(0);  // HERE

But I couldn’t figure out why. The config.php states that this line should be set to force certain hostname, and GUI global settings (cogwheel -> Global Settings) is showing correct value there.

Can anybody point me in the right direction here?

Check here for the first issue you talking about

Wow, can’t believe I couldn’t find this. Thank you @Kevin_Krumm!

I also noticed there will only checked DB status if you applied “$config[‘update’] = 0;” in your config.php.