Dashboard, "Home" Site Issues using sub-directory

Tags: #<Tag:0x00007f8d4bdd31c0>

Also, odd - but I can’t select the dashboard from the Web GUI config. Hmmm.

OK, even more interesting … :rofl:. If I go to my (only) dashboard, it’s at a URL ending in,
overview?dashboard=3

But if I edit config.php, and set,
$config['webui']['default_dashboard_id'] = 3;

Then in the Web UI config, I can’t even select a dashboard => it’s blank, and I just get a “do not enter” sign, no options in the pull-down. If I change to,
$config['webui']['default_dashboard_id'] = 0;

Then the Web UI still shows the do not enter sign, but indicates “No Default Dashboard”.

If I remove the entry from config.php, then then I can access the pull-down, but no options to select from :frowning_face:.

Thoughts?

Thanks!

Hello Arrmo,

I don’t have any concrete ideas for you (I’m just a LibreNMS user… not a dev or anything), but thought I’d throw these ideas out for you:

  • Make sure when you’re testing you do so as an admin user? (If you’re not already testing that way). Might help you isolate access issues.
  • If you are comfortable with MySQL… you could examine the ‘dashboards’ table and the ‘users’ table. Those two tables will indicate the dashboard_id (if you should set it to ‘3’ or to ‘0’), what access level those have (if they are shared or read-only), and the ‘user_id’ field will show who owns that dashboard (which you can look at the “users” table to determine). I guess I should mention that you cause a lot of problems if you make changes in the database, so maybe leave it alone if you’re not comfortable with MySQL.
  • I’ll mention the personal preferences again… when you deleted all dashboards did LibreNMS update your personal preference’ Dashboard setting?

Good Luck,
Todd

FYI, seems others are having the same issue - a workaround captured here,

Thanks!