Device groups map showing entire network instead of just group members

Im running into a problem where the device groups map no longer shows my devices according to group belonging, it just shows the entire network instead, no matter wich group i chose to view.

The device groups themselves seems to be working fine, if I list the members of a group from Devices -> Device Groups it lists them properly. (Im grouping them by subnet ex: %ipv4_addresses.ipv4_address ~ β€œ^(172.19.9.(?:6[4-9]|7[0-9]))$”)

I got aware of this problem just the other day but im not entirely sure when it all started, it has worked fine before and we have done no changes to the device groups patterns or such.

Ive tried to delete a group and add it back in with the same pattern but with the same reults, it matches all the devices correctly in Device -> Device Groups but the map is still showing the entire network.

Grateful for any type of help!


Output from ./validate.php:

Component Version
LibreNMS 1.51-55-ge599487
DB Schema 2019_02_10_220000_add_dates_to_fdb (132)
MySQL 10.0.38-MariaDB-0ubuntu0.16.04.1
RRDTool 1.5.5


[OK] Composer Version: 1.8.5
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct
[WARN] Some devices have not been polled in the last 5 minutes. You may have performance issues.
Check your poll log and see:

I’m seeing the same thing also. I don’t know what the issue is.

Looks like a fix in the works from @slashdoom

1 Like

That was fast, thanks for the heads up!