Device specific alerts applying to all devices since Jan 15th update

Tags: #<Tag:0x00007f9755b0d1c0>

Since my install updated to [1.59-28-g7a8d0b9e0 - Wed Jan 15 2020 17:40:01 GMT+0000] last night, all my alert rules which apply to single devices are now applying to all devices. Alert rules config still shows the correct devices in the list. I’ve emptied the lists and re-added the devices.

Has this happened since the invert list option has appeared? I’ve not noticed that before. It is switched off.

Thanks in advance!

James

Same problem here [1.59-28-g7a8d0b9 - Wed Jan 15 2020 14:40:01 GMT-0300]

@basicmonkey , did you fix it by removing and readding the devices?

Unfortunately not. Stuck with memory and application alerts for 10s of devices that it shouldn’t be applied to.

Run updates again.

1 Like

Much better! Thanks Kevin. What was it?

@louis can you check this out?

@basicmonkey it’s being looked here https://github.com/librenms/librenms/pull/10954

@basicmonkey please do on your librenms directory

git pull
./daily.sh

Thanks Louis, I did a pull and daily when Kevin replied and all seems well now thanks.

@basicmonkey It seems I have reproduced your issue. Alert rules was bugged when devices was on “map to” field.

PR11038 add again the feature and should fix the issue. Could you please test it works for you ?

./scripts/github-apply 11038

Get an ID of a device not in map to. Do:
./poller.php -h ID -m ports

At the bottom of the output, you will have the matching rules. Check that the rules that wrongly match because of the bug does not match again.

### Start Alerts ####
Rule #1 (Not 7): Status: NOCHG
Rule #2 (All): Status: NOCHG
Rule #3 (Mapto 5,7,8): Status: NOCHG
Rule #5 (Not all): Status: NOCHG
Rule #7 (5): Status: NOCHG
Rule #8 (Not 1): Status: NOCHG
Rule #9 (1): Status: NOCHG
#### End Alerts ####

Revert after test:

./scripts/github-remove -d

Hi louis,

Sorry for the late reply.

I tried applying that patch but I received lots of match errors. I’m guessing because it’s already been merged in?

Running the poller shows that devices not mapped are not being matched to alerts, all is well!

Thanks very much for the support.

James

@basicmonkey I has been already merged. Thanks for the reply