Disable Cisco-otv on OS level

discovery
Tags: #<Tag:0x00007f64e3908450>

#1

Hi

For some reason the global config is overwritten at O/S level for Cisco-OTV.

but Cisco-OTV is still active:

seems like the solution is to disable the Cisco-OTV module at O/S level, but I can’t figure out the right config line to do this.

I currently try the config line below, but it doesn’t do the trick.

// Disable OS poller modules
$config[‘os’][‘cisco’][‘poller_modules’][‘cisco-otv’] = 0;

Can someone guide me?

Is there a easy way to get overview of all the config parameters which can be configured in config.php ?

Best Regards Mogens


#2

its $config['poller_modules']['cisco-otv'] = false;

https://docs.librenms.org/Support/Poller%20Support/


#3

Hi Kevin

yes that config disables the global part, but it seems like the OS config is to poll and discover and for some reason that takes precedense.


#4

its not polling it… nothing on the graphs.


#5

Yes, and it shouldn’t now that I inserted the config you suggested, but for some reason the Cisco-OTV seems to be active and not returning any result.
It is actually not in the list of polled modules, but the Routing tab still shows OTV.

Seems like discovery and poller module config is overrulled by os module config.


#6

Yes… After you have it added, it is not auto-removed from database so you should remove it manually.


#7

thanks, can’t you guide me howto to do the clean up


#8

The way to disable the OTV at O/S level is this config line.

$config[‘os’][‘ios’][‘poller_modules’][‘cisco-otv’] = false;
$config[‘os’][‘iosxe’][‘poller_modules’][‘cisco-otv’] = false;