Disable lmsensors for VMWare hardware


#1

When asking for help and support, please provide as much information as possible. This should include:

  • Steps to reproduce an issue.
    VMs in VMWare have a temperature of 100. I would like to globally disable the lmsensors polling if VMWare hardware is seen.

  • The output of ./validate.php

If it’s an issue with the WebUI then please consider including a screenshot and the browser version you are using.

If you are having troubles with discovery/polling include the pastebin output of:

./discovery.php -h HOSTNAME -d | ./pbin.sh
./poller.php -h HOSTNAME -r -f -d | ./pbin.sh

If you need to post any text longer than a few lines, please use a pastebin service such as https://p.libren.ms using non-expiring pastes.


#2

Is it you don’t want to see the incorrect temperature? or is it causing issues with alerts?

You could try some of the solutions mentioned here https://www.reddit.com/r/sysadmin/comments/7hhdnj/disable_temperature_monitoring_in_librenms/

Or it looks like you could turn off the sensor modules for particular device / os i think
https://docs.librenms.org/Developing/os/Settings/#poller-and-discovery-modules


#3

Correct. Since it’s a VM it shows 100 all the time. I don’t have any alerts enabed for temp it just bothers me that the data is there and it’s inaccurate.