Distributed Poller Issues

I’m setting up a server with a brand new install of Librenms and having issues setting up the distributed polling. I’ve scoured the interwebz to find a solution but not having any luck.

===========================================

Component Version
LibreNMS 25.3.0-31-g68e8c2a90 (2025-03-21T00:39:44-05:00)
DB Schema 2025_03_17_144000_drop_ospfv3nbrifindex (322)
PHP 8.3.6
Python 3.12.3
Database MariaDB 10.11.8-MariaDB-0ubuntu0.24.04.1
RRDTool 1.7.2
SNMP 5.9.4.pre2
===========================================

[OK] Composer Version: 2.8.6
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database connection successful
[OK] Database Schema is current
[OK] SQL Server meets minimum requirements
[OK] lower_case_table_names is enabled
[OK] MySQL engine is optimal
[OK] Database and column collations are correct
[OK] Database schema correct
[OK] MySQL and PHP time match
[OK] Distributed Polling setting is enabled globally
[OK] Connected to rrdcached
[FAIL] Poller is not running. No poller has run within the last 300 seconds.
[OK] Dispatcher Service not detected
[OK] Locks are functional
[FAIL] Python wrapper cron entry is not present
[OK] Redis is functional
[OK] rrdtool version ok
[OK] Connected to rrdcached

Also in Settings > Poller there are no pollers present. I feel like the issue is the Dispatcher Service but at a loss on why it is not detected or how to fix it. I have followed every direction I can find to the letter and zip so I’m looking to the experts now.

Just solved my own issue. The problem was the dispatcher service couldn’t connect to the database. I fixed this by changing the DB_HOST to point to the IP and this got everything going.