False positive device down - LibreNMS 1.38-48-gfbbc257

It is recommended to configure the triger to be %macros.device_down = “1” && %devices.status_reason = “icmp” to fix the issue of false positive device down.

However, with LibreNMS 1.38-48-gfbbc257, ‘devices.status_reason’ is not found.

Any help would be much appreciated.

If you want to have alert rule alert only on icmp it would have to look like this this

Keep in mind the device will still be makred down in the web ui for SNMP. You should really check the event logs and also fix the snmp time out by adjusting the snmp settings.

Thanks Kevin for the screenshot and advise.

It is interesting.

Before I created this topic, I had entered ‘devices.status_reason’ while editing alert rules and got a response ‘No results found’ under the searching box.

As per your screenshot, ‘devices.status_reason’ still showed ‘No result found’, but ‘devices.status’ was available. After ‘devices.status’ was selected, ‘devices.status_reason’ is available. Perfect.

On your advice, I’d tune the snmp timeout and retries on device level first.