For false:FalseClass [NoMethodError]

Tags: #<Tag:0x00007fed73900a70> #<Tag:0x00007fed739008e0>

Hi everyone, please help me resolve this issue. Oxidized was working fine until this morning.


2021-11-16 12:54:17 UTC
undefined method `+’ for false:FalseClass [NoMethodError]

/var/lib/gems/2.7.0/gems/oxidized-0.28.0/lib/oxidized/node.rb:184:in resolve_repo' /var/lib/gems/2.7.0/gems/oxidized-0.28.0/lib/oxidized/node.rb:30:in initialize’
/var/lib/gems/2.7.0/gems/oxidized-0.28.0/lib/oxidized/nodes.rb:21:in new' /var/lib/gems/2.7.0/gems/oxidized-0.28.0/lib/oxidized/nodes.rb:21:in block (2 levels) in load’
/var/lib/gems/2.7.0/gems/oxidized-0.28.0/lib/oxidized/nodes.rb:16:in each' /var/lib/gems/2.7.0/gems/oxidized-0.28.0/lib/oxidized/nodes.rb:16:in block in load’
/var/lib/gems/2.7.0/gems/oxidized-0.28.0/lib/oxidized/nodes.rb:130:in synchronize' /var/lib/gems/2.7.0/gems/oxidized-0.28.0/lib/oxidized/nodes.rb:130:in with_lock’
/var/lib/gems/2.7.0/gems/oxidized-0.28.0/lib/oxidized/nodes.rb:10:in load' /var/lib/gems/2.7.0/gems/oxidized-0.28.0/lib/oxidized/nodes.rb:125:in initialize’
/var/lib/gems/2.7.0/gems/oxidized-0.28.0/lib/oxidized/core.rb:14:in new' /var/lib/gems/2.7.0/gems/oxidized-0.28.0/lib/oxidized/core.rb:14:in initialize’
/var/lib/gems/2.7.0/gems/oxidized-0.28.0/lib/oxidized/core.rb:4:in new' /var/lib/gems/2.7.0/gems/oxidized-0.28.0/lib/oxidized/core.rb:4:in new’
/var/lib/gems/2.7.0/gems/oxidized-0.28.0/lib/oxidized/cli.rb:13:in run' /var/lib/gems/2.7.0/gems/oxidized-0.28.0/bin/oxidized:8:in <top (required)>’
/usr/local/bin/oxidized:23:in load' /usr/local/bin/oxidized:23:in

config file


username: username
password: password
model: junos
resolve_dns: true
interval: 3600
use_syslog: true
debug: true
threads: 30
timeout: 20
retries: 3
prompt: !ruby/regexp /^([\[email protected]]+[#>]\s?)$/
rest: 127.0.0.1:8888
next_adds_job: false
vars: {}
groups: {}
models: {}
pid: “/home/oxidized/.config/oxidized/pid”
crash:
directory: “~/.config/oxidized/crashes”
hostnames: false
stats:
history_size: 10
input:
default: ssh, telnet
debug: true
ssh:
secure: false
ftp:
passive: true
utf8_encoded: true
output:
default: git
git:
user: oxidized
email: [email protected]
repo: “/home/oxidized/configbackup/git-repos/default.git”
source:
default: http
debug: true
http:
url: http://librenms/api/v0/oxidized
scheme: https
secure: false
map:
name: hostname
model: os
group: group
headers:
X-Auth-Token: ‘1e7d9b8443063f82d3ce4e7f53e6b491’
groups:
juniper:
username: oxidized
password: password
huawei:
username: oxidized
password: password
cisco:
username: oxidized
password: password
extreme:
username: oxidized
password: password

Please kindly help. Still stuck with this error. Thank you.

Eventually managed to resolve this. Had to change the “Global Settings” > “External” > “Oxidized” > “Set the default group returned” - defaultgrp. Same group was created in Oxidized config file.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.