Gaps in graphs (250+ devices)

<%- if @topic_view.topic.tags.present? %>
<%= t 'js.tagging.tags' %>: <%- @topic_view.topic.tags.each do |t| %> <%= t %> <%- end %>
<% end %>

Hello. We have a problem with gaps when there are 250+ devices. Can anybody help?
./validate.php

Component Version
LibreNMS 1.54
DB Schema 2019_07_03_132417_create_mpls_saps_table (139)
PHP 7.3.9
MySQL 5.6.45
RRDTool 1.7.2
SNMP NET-SNMP 5.8

====================================

[OK] Composer Version: 1.9.0
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct

Typically when we see this, it’s because the polling server cant keep up. Might try to add additional pollers or increase the server specs if a VM.

Thank you.

Hi Kathy_kathy
What solution did you implement to resolve your problem?

  1. Decrease polling interval? Reverse of https://docs.librenms.org/Support/1-Minute-Polling/
  2. Add additional pollers? See https://docs.librenms.org/Support/Performance/
  3. Add resources to your VM?
  4. Distributed pollers? See https://docs.librenms.org/Extensions/Distributed-Poller/

Hello.
I distributed pollers for 2 groups (servers and network devices), it got better but not at all. I don’t know if I could reopen this topic.

For the first group (548 devices) it takes 350-400 +/- sec, but sometimes it can be successfully drawn in graphs.
For the second group (71 devices) it takes 200 +/- sec and most of the time it’s ok with graphs, but not all the time.

I suppose there are some polling problems because of bad discovering too.
I’m trying to disable some poller and discovery modules, but it still takes too much time:
614 devices discovered in 33551 secs

Unfortunately, the problem is not solved.