Graph 'Update' Not Utilizing Base URL

When I am viewing a graph for a device, there are a ‘From’ and ‘To’ fields that can be adjusted to set the time range for the graph. When I click on the ‘Update’ button, I get a 404 error for the resulting page.

Upon inspection of the generated HTML, it looks like the base URL that’s configured in the config.php file is not being applied to this graph update mechanism.

I’m running this installation inside of a Docker container with an image cloned from the jarischaefer/docker-librenms project. In addition, I’m reverse proxying the site via Nginx such that my URL is

[email protected]:/opt/librenms# ./validate.php 
Component | Version
--------- | -------
LibreNMS  | 1.42.01
DB Schema | 257
PHP       |
MySQL     | 5.6.41
RRDTool   | 1.5.5
SNMP      | NET-SNMP 5.7.3

[OK]    Composer Version: 1.7.2
[OK]    Dependencies up-to-date.
[OK]    Database connection successful
[OK]    Database schema correct
[WARN]  IPv6 is disabled on your server, you will not be able to add IPv6 devices.
[WARN]  Your install is over 24 hours out of date, last update: Sat, 04 Aug 2018 20:07:12 +0000
        [FIX] Make sure your cron is running and run ./ by hand to see if there are any errors.
[WARN]  Your local git branch is not master, this will prevent automatic updates.
        [FIX] You can switch back to master with git checkout master
[WARN]  Your local git contains modified files, this could prevent automatic updates.
        [FIX] You can fix this with ./scripts/github-remove
        Modified Files:

$config[‘base_url’] = getenv(‘BASE_URL’);

[email protected]:/opt/librenms# env

Is this a bug or an issue with the way I have this set up?

Before hitting update, the URL will look like:


I can post screenshots if necessary

Please test and then confirm on Github if that works.