Graphs Just Messing Around

Hi Guys,

I have LibreNMS installed on a Virtual 4 core Ubuntu and have added 22 Mikrotik Devices including the Ubuntu itself.

At the start everything worked quite fine, however over time the graphs started to get gaps and most of the graphs now dont have any data at all anymore. Some devices are declared as offline as well, beside that ping is below 10ms to all of them. Polling interval is set to 180s as the poller time varies between 70 and 120 seconds. I still get syslogs from the “offline” devices as well.

A Config Validation tells me, that I’m probably having performance issues because some devices have not been polled in the last minutes (yeah it seems so, right?)

What it also says is:


Fail: We have found some files that are owned by a different user than librenms, this will stop you updating automatically and / or rrd files being updated causing graphs to fail.

Fix: sudo chown -R librenms:librenms /opt/librenms sudo setfacl -d -m g::rwx /opt/librenms/rrd /opt/librenms/logs /opt/librenms/bootstrap/cache/ /opt/librenms/storage/ sudo chmod -R ug=rwX /opt/librenms/rrd /opt/librenms/logs /opt/librenms/bootstrap/cache/ /opt/librenms/storage/


I have done this and it was gone, however it just came back writing that question.

I have tried to install rrdcached just as the instructions tell for ubuntu 16 (https://docs.librenms.org/Extensions/RRDCached/) but when I set " $config[‘rrdcached’] = “unix:/var/run/rrdcached.sock”; " in librenms/config.php, graphs just stop working at all and say “Error drawing graph”. When I comment it out, it works again as previously.

Do you have an idea what to check further?


Update:
I have run the Fix above again and Validation again is fine except:

Warning: Your local git contains modified files, this could prevent automatic updates.
Fix: You can fix this with ./scripts/github-remove

Doing this gets me the following output:

github-remove: error: one of the arguments -d/–discard -s/–save -r/–restore is required

I cant find which one makes the most sense and I dont want to delete something important.

Hello,

Check out this doc https://docs.librenms.org/Support/FAQ/#faq17

Most likely you are seeing those permissions changes is because you are running things as root try to only run as the librenms user.

Okay yes I have run

sudo composer install --no-dev

Because the validation wanted me to do it as there were “missing dependencies”.

I just realised physical memory exceeds 90% on my librenms machine. (I have 2G installed)

Upgraded to 4GB, 50% usage but no difference in performance

Just noticed a typo in the docs.

You configure rrdcached sock file to be in /run/rrdcached.sock but in librenms you are setting up /var/run/rrdcached.sock

Tbh, Im not sure whats the correct location in ubuntu, but try setting up /var/run/rrdcached.sock in both, rrdcached startup options and librenms config.php

Thank you very much for that hint, I will try that and post the result soon

Okay I testet setting both to /var/run/rrdcached.sock but as soon as I uncomment the

$config[‘rrdcached’] = “unix:/var/run/rrdcached.sock”;

it just says “error drawing graph”.

I’ve also tested

$config[‘rrdcached’] = ‘unix:/var/run/rrdcached.sock’;
with ’ instead of " for syntax reasons but it did not make a difference.

I’m also experiencing major gaps in all of my graphs and ICMP checks being stated offline even when ping is completely well…

May I try to delete the whole database and let it start over again?