HTTP 500 Errors since update

Since this morning’s update, we have an issue where loading any webui page yields a HTTP 500 error.

From logs/librenms.log we see lines like this for each HTTP request:

[2018-09-14 10:03:05] production.ERROR: exception 'Symfony\Component\Debug\Exception\FatalErrorException' with message 'Class 'Fideloper\Proxy\TrustedProxyServiceProvider' not found' in /opt/librenms/vendor/laravel/framework/src/Illuminate/Foundation/ProviderRepository.php:208 Stack trace: #0 {main} [] []

I ran validate.php and, and all appears to be well. I am wondering what has happened to cause us to be missing Laravel components, and how to fix it.


Try this as librenms user:
./scripts/composer_wrapper.php install --no-dev

Hi @TheGreatDoc,

Thanks - I’m not longer getting HTTP 500 errors, but the webui is still broken. It loads the menu bar, but then ceases.

In librenms.log, there is a line like the following per HTTP request:

[2018-09-14 11:12:20] production.ERROR: 8 /opt/librenms/html/legacy_index.php:113 Undefined index: custom_css  

validate.php and didn’t help, and neither did php artisan cache:clear which I thought might have kicked it back to life.

@ashaw Are you running php-mysql or php-mysqlnd?

If running mysql you must switch to mysqlnd

Example if running php 7.2 in Centos:
yum swap php72w-mysql php72w-mysqlnd

1 Like

Hi @TheGreatDoc

Thanks - yep, I’m running mysqlnd. I’m not up to php7 yet, though, still on PHP 5.6.33-0+deb8u1 (cli) (built: Jan 5 2018 15:46:26)

Is updating to php7 required at this point?

No, just mysqlnd instead of mysql driver.

Do you have any other error than the undefined index for custom_css?

Are you running a custom css?

No that’s the only error I can find. The corresponding access log example is:

[redacted] - - [14/Sep/2018:11:46:46 +0100] "GET / HTTP/1.1" 500 16844 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.92 Safari/537.36"

I am not running any custom css.

Ok. Lets try with this:

Tail your librenms.log and refresh web. Then pastebin (with care for confidential data) the output pls

Unfortunately there is only the one line that is generated when I do that:


Ok, then do the same but add /debug=yes/ to the url


here you go:

Ok. That was not helpfull at all…

Im almost out of ideas. Have you tried to access from another computer/browser?

What happens if, after loggin in, you go to /devices/?

:slight_smile: it’s a weird one.

I have logged in from Chrome and Firefox and my phones browser and in all cases I have tried to navigate to /devices/ but that has yielded the same error message and displayed the same issue.

I am out of ideas.

I have a 2nd instance that didn’t break overnight, but that’s Ubuntu with php7, so not a fair comparison with this box.

The only additional point to make is that our Weathermap output is still working fine.

But that’s a static HTML file, so the Laravel/CSS issues we’re seeing aren’t involved there.

I have resolved the issue.

I found [14-Sep-2018 14:41:21 europe/london] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 32 bytes) in /opt/librenms/vendor/laravel/framework/src/Illuminate/Database/Connection.php on line 325 in the php error log.

worked for me.