I can´t download Librenms


When i run this command: “composer create-project --no-dev --keep-vcs librenms/librenms librenms dev-master”. I got this error: Content-Length mismatch, received 481537 bytes out of the expected 639917

I running Red Hat Enterprise Linux Server release 7.4 (Maipo)

Are you using are install docs?


Hi Kevin!

Yes i do. But i came on this stage “composer create-project --no-dev --keep-vcs librenms/librenms librenms dev-master”. efter that i got the error.

@mohammed0170 sounds like the file it is trying to download is getting corrupted.

Hi Murrant!

Is it corrupted on my site or? I tested two diffrence servers and i got the same errors on the both.

Seems like you are using composer itself to try and install LibreNMS. I’ve never used it this way and you should really go through the install docs rather.

Something on your side, like a firewall.

That was true, it was our firewall- IPS which drops this traffic. But when i run this command “composer config -g repo.packagist composer https://packagist.phpcomposer.com” it helped me. I don´t know why?. Thank you :slight_smile: