iDrac polling not working and weird validate output

Hi there,
I have a problem with 2 Dell servers. I tried to poll IPMI data.
I configured IPMI tab on each servers and installed package “ipmitool” (I’m running ubuntu)
But data is still not getting polled.

I check some posts on the internet and some said to check ./validate.php script output.

I checked the output and most of the check are in “FAILED” state : ==========================================================
Component | Version
--------- | -------
LibreNMS | d30e5660f942154bd72c1b3f6ff3846d3c1b7137
DB Schema | 199
PHP | 7.0.18-0ubuntu0.16.04.1
MySQL | 10.0.28-MariaDB-1~precise-wsrep
RRDTool | 1.5.5

[WARN]  Your install is out of date, last update: Mon, 10 Jul 2017 21:27:46 +0000
[OK]    Database connection successful
[FAIL]  Database: incorrect column (dbSchema/version)
[FAIL]  Database: missing index (dbSchema/PRIMARY)
[FAIL]  Database: missing column (users/remember_token)
[FAIL]  Database: incorrect column (users/updated_at)
[FAIL]  We have detected that your database schema may be wrong, please report the following to us on IRC or the community site (
         ALTER TABLE `dbSchema` CHANGE `version` `version` int(11) NOT NULL DEFAULT '0';
         ALTER TABLE `dbSchema` ADD PRIMARY KEY (`version`);
         ALTER TABLE `users` ADD `remember_token` varchar(100) NULL AFTER `realname`;
         ALTER TABLE `users` CHANGE `updated_at` `updated_at` timestamp NOT NULL DEFAULT CURRENT_TIMESTAMP;
[FAIL]  You have no timezone set for php. [FIX]
[WARN]  Your local git contains modified files, this could prevent automatic updates.
Modified files:

What do you advise me to do ?
Can I fix these errors or do I reinstall LibreNMS and reimport ?

run these quiries in the database ALTER TABLE dbSchema CHANGE version version int(11) NOT NULL DEFAULT ‘0’;
ALTER TABLE users ADD remember_token varchar(100) NULL AFTER realname;
ALTER TABLE users CHANGE updated_at updated_at timestamp NOT NULL DEFAULT CURRENT_TIMESTAMP;

Also run from cli: cp librenms.nonroot.cron /etc/cron.d/librenms

and fix your php time zone…set it in php.ini

Thanks a lot Kevin, I didn’t understand in the valide.php result I had to did that x).
My iDrac problem came from another problem, I just didn’t activate IPMI on both iDrac.

1 Like

Not sure what you’ve changed in librenms.cron.nonroot but you shouldn’t be editing that file. You should copy it to /etc/cron.d/librenms and edit that new file.

Well, I didn’t change anything in librenms.nonroot.cron. I will reset this file on next update.