Important custom device we poll seems to have stopped working


There is the main LibreNMS server (not docker) and 2 additional pollers (docker).

Component | Version
--------- | -------
LibreNMS  | 23.2.0-7-gdda317613 (2023-03-01T00:10:45+00:00)
DB Schema | 2022_08_15_084507_add_rrd_type_to_wireless_sensors_table (248)
PHP       | 8.1.2-1ubuntu2.11
Python    | 3.10.6
Database  | MariaDB 10.6.12-MariaDB-0ubuntu0.22.04.1
RRDTool   | 1.7.2
SNMP      | 5.9.1

[OK]    Composer Version: 2.5.4
[OK]    Dependencies up-to-date.
[OK]    Database connection successful
[OK]    Database Schema is current
[OK]    SQL Server meets minimum requirements
[OK]    lower_case_table_names is enabled
[OK]    MySQL engine is optimal
[OK]    Database and column collations are correct
[OK]    Database schema correct
[OK]    MySQl and PHP time match
[OK]    Distributed Polling setting is enabled globally
[OK]    Connected to rrdcached
[OK]    Active pollers found
[OK]    Dispatcher Service is enabled
[OK]    Locks are functional
[OK]    Python wrapper cron entry is not present
[OK]    Redis is functional
[OK]    rrdtool version ok
[OK]    Connected to rrdcached
[WARN]  Your local git contains modified files, this could prevent automatic updates.
	You can fix this with ./scripts/github-remove
	Modified Files:

I’m not sure where to start on this as it was working some time ago where we polled 100s of custom devices and it would return their custom data. These devices are digital factory screens.

I’ll use these 2 as examples on the same subnet:

You can see 1 is pulling 11 addition metrics and the other isn’t, we have 100s like this:

If I go into both I see this below. Here is the good one and you can see all my custom data, but the logs show discovery errors:

Here is an example of a broken one:

If I run this discovery against the bad one I get this:

./discovery.php -h -v -d -m sensors

However it seems to show the values I need, but I don’t seem them in the GUI.

Here is the same discovery against the one that does show in the GUI.

> ./discovery.php -h -v -d -m sensors

To me it shows the same working data, but why does this one show, unless it’s cached.

Could it be the the additional pollers causing this? What steps can I run next to troubleshoot and paste back here?


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.