Install on Raspbian stretch


I’m trying to following these instructions to install LibreNMS on a raspberry pi:

Unfortunately, I’m stuck here:

composer create-project --no-dev --keep-vcs librenms/librenms librenms dev-master
Do not run Composer as root/super user! See for details

  Could not find package librenms/librenms with version dev-master in a version installable using your PHP version 7.0.33.

It seems the older version should install on Raspbian stretch, but the dev-master is looking at the most recent release, which requires PHP 7.1.

I’d prefer to stick to a standard Raspbian build than to try to upgrade it to buster. How do I get the older LibreNMS installed?

Take a look to LibreNMS on Raspberry Pi

Right, that just says to follow the instructions I was following, with the comment that

php5 will no longer be supported soon

I don’t need to run the March 2019 LibreNMS, I’d be quite happy with the Dec 2018 version. I just don’t see how to force composer to install the older version.

Stretch has PHP 7.0, but not the 7.2 which is required.

if you have the git repo already:

git checkout 1.48.1
./scripts/composer_wrapper.php install --no-dev
Continue install process

And disable updates in config.php

1 Like