Is delay setting broken?

I’m trying to set a ten minute delay on some of my alerts, but it does not seem to be working. Is this feature broken?

I don’t think so. What have you set it to?

I set delay to ten minutes in an effort to either give the alert a chance to clear, or fire twice before alerting. As soon as the alert fires I get an email in PagerDuty.

What’s the actual value?

In the rule the delay setting is 10 m. On the list of rules delay is displayed as 600.

I’ve just tested this and it worked fine for me:

Please post the output ./validate.php

Here is the requested output:

[root@librenms librenms]# ./validate.php

Component Version
LibreNMS 376323f00eae113129610c8ec444632aa979c017
DB Schema 156
PHP 7.0.12
MySQL 5.5.50-MariaDB
RRDTool 1.4.8


[OK] Database connection successful
[FAIL] You have a different system timezone (EST) specified to the php configured timezone (UTC), please correct this.

Here is the timezone section from php.ini:
; Defines the default timezone used by the date functions
date.timezone =“America/New York”

Fix that :slight_smile:

The system time zone is EST, as is the time zone in php.ini. Is there some place else that I need to update?

From the validate output it’s showing you that your system tz is EST but php is configured UTC. Whichever one is wrong you need to update as we can’t change that for you.

My php.ini file is currently set to EST:

; Defines the default timezone used by the date functions
date.timezone =“America/New York”

Is there another setting I need to change to make php use the EST time zone?

Have you got the right php.ini file? On debian/ubuntu you have two.

Thanks for helping me work through this. I’m running CentOS 7, but your question led me to the solution.

[root@librenms librenms]# php -i | grep php.ini
Configuration File (php.ini) Path => /etc
Loaded Configuration File => /etc/php.ini
PHP Warning: Unknown: Invalid date.timezone value ‘America/New York’, we selected the timezone ‘UTC’ for now. in Unknown on line 0

The missing underscore in New York caused the time zone to be an invalid format.