LDAP authentication fails. Compare False

Hi guys. I’m trying to configure ldap authentication, but when I run ./scripts/auth_test.php I’m getting an
Error: LibreNMS\Exceptions\AuthenticationException thrown!
Compare False
On my ldap server the following lines are logged:
BIND dn=“uid=lnms3,ou=People,dc=mycomp,dc=com” method=128
BIND dn=“uid=lnms3,ou=People,dc=mycomp,dc=com” mech=SIMPLE ssf=0
RESULT tag=97 err=0 text=
CMP dn="" attr=“memberUid”
RESULT tag=111 err=16 text=
CMP dn=“cn=lnms,ou=group,dc=mycomp,dc=com” attr=“memberUid”
RESULT tag=111 err=5 text=

I defenetly have this user lnms3 in the lnms group, I can see it with ldapsearch, but for librenms lookup gets failed for some reason.
Here is my config:
$config[‘auth_ldap_version’] = 3;
$config[‘auth_ad_check_certificates’] = 0;
$config[‘auth_mechanism’] = ‘ldap’;
$config[‘auth_ldap_server’] = ‘ldap://ldap.mycomp.com’;
$config[‘auth_ldap_suffix’] = ‘,ou=People,dc=mycomp,dc=com’;
$config[‘auth_ldap_groupbase’] = ‘ou=group,dc=mycomp,dc=com’;
$config[‘auth_ldap_prefix’] = “uid=”;
$config[‘auth_ldap_groups’][‘lnms’][‘level’] = 10;
$config[‘auth_ldap_userdn’] = true;

Am I missing something?

I have the same problem. It only occurs with new users (existing LDAP users are not affected by this issue).

I tried to add the user manually to the database (user table) but even after that this error keeps happening.

I wonder if there is any solution for this issue?

Try setting a bind user.

Apparently, a user without groups (linked to roles in LibreNMS) cannot log in to LibreNMS. Previously, they could. Now they get a strange error message instead of an empty LibreNMS environment.

So you can solve the problem by adding the user to the group. The user must have permissions to read the group members. If you don’t want to give these permissions you can indeed use a bind user.