Librenms.log grows very large very quickly (grows more than 100 kb per sec)

Hi everybody,

The librenms.log file grows very fast at 100 kb per sec.
Had to delete it because otherwise there would be no more space left on the server.
When I look in the log file, I see a number of errors. Can someone help me to solve this?
I’ve checked everything and everything seems to be fine. Username, password and server are correct. And the portal (WebUI) simply displays all data correctly.

  • The output of ./validate.php
    Component | Version
    --------- | -------
    LibreNMS | 21.10.2
    DB Schema | 2021_10_03_164200_update_hrsystem_table (221)
    PHP | 7.4.14
    Python | 3.6.8
    MySQL | 10.5.9-MariaDB
    RRDTool | 1.4.8
    SNMP | NET-SNMP 5.7.2

[OK] Composer Version: 2.1.9
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct
[WARN] Your local git contains modified files, this could prevent automatic updates.
You can fix this with ./scripts/github-remove
Modified Files:

The errors I get in librenms.log:
[2021-10-24 10:39:52] production.ERROR: PDOException: SQLSTATE[HY000] [2002] Permission denied in /opt/librenms/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:40

Next Doctrine\DBAL\Driver\PDO\Exception: SQLSTATE[HY000] [2002] Permission denied in /opt/librenms/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDO/Exception.php:18

Next Illuminate\Database\QueryException: SQLSTATE[HY000] [2002] Permission denied (SQL: select * from config where (config_name = rrdtool_version) limit 1) in /opt/librenms/vendor/laravel/framework/src/Illuminate/Database/Connection.php:703

After those 3 errors it starts again with the same errors over and over again.

Hope someone can help.

Tia, ragards,

You have MySQL permissions problems. Also, make sure you enabled logrotate as described in the docs.

Hi thanks for your reply!
Looks like a sql problem I know. But I have logged into mysql with the credentials used by the script and can acces the tables/data. What kind of permissions can be the probem then?



Problem was solved after I changed the ‘DB_HOST’ setting in ‘/opt/librenms/.env’ file.
Old setting: DB_HOST=localhost
New setting: DB_HOST=


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.