LNMS suddenly stoped sending notifications

Hi guys , as you can see my system is up to date but it is not sending notifications.

bash-4.2$ ./validate.php
====================================
Component | Version
--------- | -------
LibreNMS  | 21.2.0-45-ge3ee464
DB Schema | 2021_02_21_203415_location_add_fixed_coordinates_flag (200)
PHP       | 7.3.27
Python    | 3.6.8
MySQL     | 10.5.9-MariaDB
RRDTool   | 1.4.8
SNMP      | NET-SNMP 5.7.2
====================================

[OK]    Composer Version: 2.0.11
[OK]    Dependencies up-to-date.
[OK]    Database connection successful
[OK]    Database schema correct

This is my production server so … im very worried.
I have been some similar issues but any of them was helpfull for me.
Testing alerts and templates with using test-XXX scripts works as expected.
And:

[[email protected]_wiber librenms]# ./alerts.php -d
DEBUG!
SQL[update `cache_locks` set `owner` = ?, `expiration` = ? where `key` = ? and (`owner` = ? or `expiration` <= ?) ["SHX05e7wBMqKTtjr",1615479903,"laravel_cachealerts","SHX05e7wBMqKTtjr",1615479843] 0.6ms]

Last check:
Looking at Alerts -> Notifications:
I can properly see notifications been sent.
BTW , Im using telegram transport only.

please help me !!
Leandro

Does the test transport work ?

yes … it works.

Im trying isolate de problem.
Until now I can not find any clear sign of fault but after removing all my templates I got some notifications.
I thought I have founded the problem but not , I can not recreate the situation.
I need to keep working on this.
Perhaps if I had some notification logs I could get more info.
Regards.
Leo.

Are you using distributed pollers ? Dispatch-service ?

Nop …
I was able to isolate the problem though.
Dont know what happened but this is how I got my notifications back.
I sent all my notifications to default template.
Then begin setting one by one to correspoinding templace and force alerting to test.
Im almost done bringing to original config and still dont know where the problem was or is still present.
Regards.

This topic was automatically closed 186 days after the last reply. New replies are no longer allowed.