MySQL tables collation

I am still in the process of getting LibreNMS setup, and I ran ./validate.php and managed to correct all the errors except one.
Here is what it’s telling me:


Component Version
LibreNMS 1d80a0d2a689e2f91ed72d614313aabc992529f2
DB Schema 171
PHP 7.0.15-0ubuntu0.16.04.4
MySQL 10.0.29-MariaDB-0ubuntu0.16.04.1
RRDTool 1.5.5


[OK] Database connection successful
[FAIL] MySQL tables collation is wrong: [FIX]
port_in_measurements utf8 utf8_general_ci
port_out_measurements utf8 utf8_general_ci

I have followed the instructions given in the link, but it still says it failed.
I’m very new to linux, so it’s possible that I did it incorrectly even though it didn’t give me any errors when I ran the commands.
Any thoughts?

Hi, i think it was something like;
echo ‘ALTER DATABASE librenms CHARACTER SET utf8 COLLATE utf8_unicode_ci;’ | mysql -p -u librenms librenms

Thats what i ran on my system when i had a similar problem.

Those tables should not exist anymore they were removed.

DROP TABLE port_in_measurements;
DROP TABLE port_out_measurements;
echo 'DROP TABLE port_in_measurements;DROP TABLE port_out_measurements;' | mysql -p -u librenms librenms

Looks like that did the trick.
Thanks for the help!