New install, two issues after running validation

I always seem to have a problem with timezones. I’m either not understanding what needs to be done or making a mistake with my entries/syntax.

Ensure date.timezone is set in php.ini to your preferred time zone.
See for a list of supported timezones. Valid examples are: “America/New_York”, “Australia/Brisbane”, “Etc/UTC”.

vi /etc/php/7.2/apache2/php.ini
vi /etc/php/7.2/cli/php.ini

I opened both of those files with vi and searched for date.timezone and added “America/Chicago” in each file. I did this during the install. Running validation I get the error above.

Is there a 3rd (or more) php.ini file(s)? If so, where are they located?

Git Hub issue (resolved)

Warning: Your local git contains modified files, this could prevent automatic updates.

Fix: You can fix this with ./scripts/github-remove

When I run sudo ./scripts/github-remove I get this, ./scripts/github-remove: command not found

When I run -bash: ./scripts/github-remove I get ./scripts/github-remove: No such file or directory

Git Hub issue (resolved)

Another question that I have to ask since visiting the site, today. I see a banner stating:

Users of daily updates (the default), your installs will no longer update without a little manual intervention.

It will not be an issue for those on the monthly updates.

You will need to update LibreNMS manually to resolve the issue.

su - librenms
git pull

I assume this is something I need to run, as well, or will validation tell me if I need to do anything else?


Edit- Fixed the git hub issue, I was in /opt not in /opt/librenms.

Here is where I’m currently at. Last time I asked about this I still wasn’t able to fix it, but I’ll give it another shot if I can get some assistance. Obviously I’m missing something.

Component Version
LibreNMS 1.58.1-21-gb555edee5
DB Schema 2019_10_03_211702_serialize_config (147)
PHP 7.2.24-0ubuntu0.18.04.1
MySQL 10.1.43-MariaDB-0ubuntu0.18.04.1
RRDTool 1.7.0


[OK] Composer Version: 1.9.1
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct
[FAIL] You have no timezone set for php.


Here are the files where I got my timezone set:

date.timezone = Europe/Warsaw
date.timezone = Europe/Warsaw

Check what PHP version you have enabled, or try by:

librenms:[/etc]#php -v
PHP 7.2.24-1+0~20191026.31+debian9~1.gbpbbacde (cli) (built: Oct 26 2019 14:18:28) ( NTS )

Then make sure you got Apache Mod 7.2 enabled (maybe you are still running 7.0)?

@limes-github I didn’t see this post until now. Before I saw this, I tried editing the timezone by running a specific time zone command which caused mysql errors the next time I tried to validate. If someone can help correct this mysql error, I’d appreciate that. While the validate file does tell me which mysql statements to run, I’m not sure how/where to run those statements.

This is the timezone command I ran: cp /usr/share/zoneinfo/America/Chicago /etc/localtime

Here is the mysql fix:

ALTER TABLE notificationsCHANGEdatetime datetime timestamp NOT NULL DEFAULT '1970-01-02 00:00:00' ;


ALTER TABLE usersCHANGEcreated_at created_at timestamp NOT NULL DEFAULT '1970-01-02 00:00:01' ;

Anyone? I’d like to avoid a rebuild. Thank you.

Whats the output of this;
date +%Z
php -r "echo date('T');"


Whats the output of this;
date +%Z
php -r "echo date('T');"

Am I running those are separate commands? If so, I see CST for both.