No data in webgui

After update to 1.31.01 my gui is empty. No devices no data shown.

./validate output:

I’m able to login into mariadb with the db user supplied in config.php
The devices are there when i ran select * from devices;

SQL debug

PHP debug

I don’t really know where to look next
Please advise


What does gui is empty mean?

if it’s totally a blank white screen then most likely php max mem. Add /debug=true/ to the end of the url to see more info.

Image of my devices:

See for PHP debug:

I cant see any php memory errors

Open your javascript console, refresh the page and see what it says

Hi - I am also facing the exact same issue on our install - the version is:
LibreNMS | 1.31.01

We have noticed that this worked on an older version of Chrome but the machines are now running the following version: Version 60.0.3112.113 (Official Build) (64-bit) and we cannot rollback (due to corporate lockdowns)

When refreshing that page with the console the only output I get is:

[Deprecation] Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience. For more help, check

Apologies for jumping on this thread - I can create a new one if that is preferable


1 Like

this is a shot in the dark but have you tried increasing memory in php?

What authentication mechanism are you using? It looks like you have authenticated, but your userlevel is 1.

Nice catch, that seems to be the issue.
Using ad-authentication. I guess I have to troubleshoot why that isn’t working.


Thanks for the information murrant - I am also using AD-Authentication however the auth_test.php script seems to imply all is working correctly:

bash-4.2$ php auth_test.php -u rgameuk -d -v
SQL[DELETE FROM session WHERE session_expiry < ‘1504102209’]
Authentication Method: active_directory
AD bind success
Authenticate user rgameuk:

user_id => 50
username => rgameuk
realname => Rob Game
email => [email protected]
descr =>
level => 0
can_modify_passwd => 0
twofactor => 0
Groups: Required-Group-1; Required-Group-2

(Data has been replaced due to security procedures here)

And from config:
$config[‘auth_ad_require_groupmembership’] = true;
$config[‘auth_ad_groups’][‘Required-Group-1’][‘level’] = 10;
$config[‘auth_ad_groups’][‘Required-Group-2’][‘level’] = 5;

As this has occurred for myself and anderssonpof since upgrading (and we appear to have the same setup) has anything changed in LDAP/AD auth with the latest daily? (1.31.01)

Thanks again for your help!

We’ve done some updates, go to latest master or 1.31.02. Should be fixed AD auth.