No fping/performance graphs and no location discovery with fresh install on RaspberryPi4


I just recently installed LibreNMS on a Raspberry Pi4 and except from some issues it is working fine. I used these instructions to install it except that I used php7.3 instead of php7.2.

This is the output of ./validate.php:

Component | Version
--------- | -------
LibreNMS  | 1.59-20-gdc3fe103a
DB Schema | 2020_01_09_1300_migrate_devices_attribs_table (153)
PHP       | 7.3.11-1~deb10u1
MySQL     | 10.3.17-MariaDB-0+deb10u1
RRDTool   | 1.7.1
SNMP      | NET-SNMP 5.7.3

[OK]    Composer Version: 1.9.1
[OK]    Dependencies up-to-date.
[OK]    Database connection successful
[OK]    Database schema correct

My current Problem is that no graphs are drawn in the Perfomance tab of the devices and that the location discovery from address strings in the SNMP information does not seam to work. I tried it with Google Maps and OpenStreetMap as geocoding engines with no luck.

Any idea how I could debug this issues?

Aside from this the load which is generated from monitoring 33 devices is quite substantial…



And I just realized that the autodiscovery seams not be working as well. Any Idea where to check?


Concerning auto-discovery, did you follow the procedure ?

The load depends on the type of devices (and the number of interfaces/sensors). In term of poller, on such a small device, it is probably a good idea to have only 4 to 6 pollers instead of the default value in cron.d/librenms.


yes I added a default community and a couple of nets in which autodiscovery should take place:

### Default community
$config['snmp']['community'] = array("public");

### List of RFC1918 networks to allow scanning-based discovery
$config['nets'][] = "";
$config['nets'][] = "";
$config['nets'][] = "";
$config['nets'][] = "";
$config['nets'][] = "";
$config['nets'][] = "";

am I missing something?

The pollers count is reduced by changing the number behind the, right?

It’s only part of it.

Unless you have a proper DNS configuration, this option is needed:

$config['discovery_by_ip'] = true;

You also need to define which method to use (ARP, xDP …). So again, please read the documentation, and you’ll have it working in no time.

DNS configurartion is in place and I now added ARP to the default enabled XDP. Thanks for the hint :smiley:.