PHP 7.2.5 is installed but not detected by UI

I have installed LibreNMS on OpenSUSE 15.1 with PHP 7.2. Everything looks good except the acces to the WebUI does not work.

I have created a new config with install.php (that works fine). After fixing some issues with the output of validate.php everything looks good. But if I try to acces the UI (http://hostname/index.php), I get the error " PHP version 7.2.5 or newer is required to run LibreNMS". But CLI and also phpinfo() show exactly that this version is installed.

Output of validate.php
[email protected]:~> ./validate.php

Component Version
LibreNMS 1.64
DB Schema 2020_04_19_010532_eventlog_sensor_reference_cleanup (165)
PHP 7.2.5
Python 3.6.10
MySQL 10.2.31-MariaDB
RRDTool 1.7.0
SNMP NET-SNMP 5.7.3

====================================

[OK] Composer Version: 1.10.6
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct
[WARN] IPv6 is disabled on your server, you will not be able to add IPv6 devices.

Result of phpinfo()
X-Powered-By PHP/7.2.5

Any ideas whats going wrong here?

Thank you!

As workaround for me I have changed app/Checks.php to version 7.2.4… After that I can use the UI finally.

...
        if (version_compare('7.2.4', PHP_VERSION, '>=')) {
...

The change makes no sense. In my opinion, the code looks correct. But as already mentioned, it is only a workaround.

Go to the validate page in the web ui. 100% it says you are not running PHP 7.2.5 in your webserver.

I don’t know what you mean with that. With which ULR I can access the validate page?

BTW: If I open “About” in the Web UI, the system information page CONFIRM that I’m using PHP 7.2.5.

In the meantime I have found the “Validat config” link. But only the time zone is not OK (database and PHP). It says nothing about wrong PHP version.

So, the “error” you are seeing is a popup message in the upper right hand corner? I thought you had described something else.

It seems your webui is working now, is that correct?

If everything is working fine, perhaps the popup notification got stuck somehow. If this is the case it may have to be manually removed from the database. If it isn’t it will just get restored if you delete it anyway.

I’m sorry for the late reply. No the issue is still there, if I restore the original file of Checks.php. I still get following error but I still use the required PHP version 7.2.5 (see screenshot 20 days before).
librenms-php7.2.5

I have changed the self::printMessage line now:

  self::printMessage(
            'PHP version 7.2.5 or newer is required to run LibreNMS (installed '.PHP_VERSION.")",
            null,
            true
        );

The output is then:
librenms-php7.2.5 modified

I’m sorry, but that make no sense to me.

I use OpenSUSE LEAP 15.1. In the next days 15.2 will be released and I hope that a new PHP version will be part of it. But perhaps this issue should be verified anyway?

It happens to have exactly 7.2.5? I’m surprised as the last released version of PHP 7.2 is 7.2.31 as of this writing.