Php/php-fpm and high CPU usage after nightly update

Component | Version
--------- | -------
LibreNMS  | 22.8.0
DB Schema | 2022_07_03_1947_add_app_data (244)
PHP       | 8.1.9
Python    | 3.8.10
Database  | MariaDB 10.3.34-MariaDB-0ubuntu0.20.04.1
RRDTool   | 1.7.2
SNMP      | 5.8

[OK]    Composer Version: 2.4.1
[OK]    Dependencies up-to-date.
[OK]    Database connection successful
[OK]    Database Schema is current
[OK]    SQL Server meets minimum requirements
[OK]    lower_case_table_names is enabled
[OK]    MySQL engine is optimal
[OK]    Database schema correct
[OK]    MySQl and PHP time match
[OK]    Active pollers found
[OK]    Dispatcher Service not detected
[OK]    Locks are functional
[OK]    Python poller wrapper is polling
[OK]    Redis is unavailable
[OK]    rrdtool version ok
[OK]    Connected to rrdcached

Posting librenms.log per request - title of post covers issue. See here for Discord discussion.

Log file: (let me know if this doesn’t work - should be a gzip file)

murrant requested I exclude SQL errors from the log, so I used the following regex to generate the gzip log: grep -Ev '(^\#[0-9]+\ |Stack trace|Too many connections|^[[:space:]]*$)' librenms.log.1

Let me know if I need to attach any additional information.

Does help?

What does ./scripts/composer_wrapper.php show facade/flare-client-php show?

Got someone to do some troubleshooting. It should be fixed after update.

Still curious as to why CPU usage was so high. I’ve had this enabled in production for a couple of weeks now.

i have same issue from midnight …from 5 to 5 minute 100 cpu usage.
What does ./scripts/composer_wrapper.php show facade/flare-client-php show?

bash-4.4$ ./scripts/composer_wrapper.php show facade/flare-client-php
name : facade/flare-client-php
descrip. : Send PHP errors to Flare
keywords : exception, facade, flare, reporting
versions : * 1.10.0
type : library
license : MIT License (MIT) (OSI approved) MIT License | Software Package Data Exchange (SPDX)
homepage :
source :213fa2c69e120bca4c51ba3e82ed1834ef3f41b8
dist : [zip] 213fa2c69e120bca4c51ba3e82ed1834ef3f41b8
path : /opt/librenms/vendor/facade/flare-client-php
names : facade/flare-client-php


Facade\FlareClient\ => src

facade/ignition-contracts ~1.0
illuminate/pipeline ^5.5|^6.0|^7.0|^8.0
php ^7.1|^8.0
symfony/http-foundation ^3.3|^4.1|^5.0
symfony/mime ^3.4|^4.0|^5.1
symfony/var-dumper ^3.4|^4.0|^5.0

requires (dev)
friendsofphp/php-cs-fixer ^2.14
phpunit/phpunit ^7.5
spatie/phpunit-snapshot-assertions ^2.0

It appears that the package is not installed.

Things have been calm since I last posted about this - CPU usage has returned to normal and the logs are not filling with SQL errors any longer. I made no changes other than running

@robdb I wonder if that is why cpu usage was high?

Your guess is as good as mine - do I need to install that package? It was odd that it just started out of nowhere.

./scripts/composer_wrapper.php install --no-dev (which is part of should install that package.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.