Poller Not running

I am having an issue with the poller. If I run the poller by itself it runs. But if I run the poller-wrapper it does not run. I get this below.

bash-4.2$ /opt/librenms/cronic /opt/librenms/poller-wrapper.py 16
Cronic detected failure or error output for the command:
/opt/librenms/poller-wrapper.py 16


Traceback (most recent call last):
  File "/opt/librenms/poller-wrapper.py", line 177, in <module>
    logger = LNMS.logger_get_logger(LOG_FILE, debug=_DEBUG)
  File "/opt/librenms/LibreNMS/library.py", line 84, in logger_get_logger
    file_handler, err_output = logger_get_file_handler(log_file)
TypeError: 'bool' object is not iterable

Cannot create logfile. Trying to obtain temporary log file.
Message: [Errno 13] Permission denied: '/root/logs/poller_wrapper.log'
Trying temporary log file in /tmp/LibreNMS.library.log
Cannot create temporary log file either. Will not log to file. Message: [Errno 13] Permission denied: '/tmp/LibreNMS.library.log'

The validate.php file runs correctly.

bash-4.2$ /opt/librenms/validate.php
Component | Version
--------- | -------
LibreNMS  | 1.70.1-45-gca157ec
DB Schema | 2020_11_02_164331_add_powerstate_enum_to_vminfo (191)
PHP       | 7.3.26
Python    | 3.6.8
MySQL     | 5.5.68-MariaDB
RRDTool   | 1.4.8
SNMP      | NET-SNMP 5.7.2

[OK]    Composer Version: 2.0.8
[OK]    Dependencies up-to-date.
[OK]    Database connection successful
[OK]    Database schema correct

I have done some searching and I cannot find any similar issue.

Delete /tmp/LibreNMS.library.log

And don’t run as root.

This topic was automatically closed 186 days after the last reply. New replies are no longer allowed.