Problem with syslog.ibd

I’m not sure, but my syslog.ibd is huge (45G).

I have $config[‘syslog_purge’] configured to 10 days and innodb_file_per_table=1 from the start.

This is normal ?

ps. dail and validate without any problems.

In the web ui under syslog how many entries do you have?

Loading took minute, but show me at the end “No results found!”

Loaded after refreshing a lot of them
Showing 1 to 50 of 20470507 entries

If you feel safe doing so just truncate the syslog table. Or change the Syslog clean option to 1 day to help clear it out. Then change it back.

MariaDB [librenms]> TRUNCATE table syslog;

I will probably try with query, because changing Syslog clean to 1 give me nothing… daily update showed that “millions” entry’s was deleted, but size of Syslog is the same…

It will be, it’s how innodb works. You’d have to dump the syslog table, drop it then re-import it to get the size back.