Radius authentification issues

Hello,

I configured radius as the authentification method. It works fine for most users, but not others.

When I’m trying to debug the problem, I tried the radtest cmd from the librenms server and it worked fine. For example:

radtest testuser testpassword 1.2.3.4 0 secretkey –> Received Access-Accept Id 120 from 1.2.3.4:1812

But when I test with the same user the auth_test.php script I get this error:

./scripts/auth_test.php -d -v -u testuser
Authentication Method: radiusPassword:Authenticate user testuser:
2025-09-19 13:54:49 DEBUG: Added Attribute 1 (User-Name), format S, value testuser
2025-09-19 13:54:49 DEBUG: Added Attribute 2 (User-Password), format S, value xxxxx
2025-09-19 13:54:49 DEBUG: Added Attribute 6 (Service-Type), format I, value 1
2025-09-19 13:54:49 DEBUG: Packet type 1 (Access-Request) sent to 1.2.3.4
2025-09-19 13:54:49 DEBUG: Attribute 1 (User-Name), length (8), format S, value xxxxx
2025-09-19 13:54:49 DEBUG: Attribute 2 (User-Password), length (16), format S, value xxxx
2025-09-19 13:54:49 DEBUG: Attribute 6 (Service-Type), length (4), format I, value 1
2025-09-19 13:54:49 DEBUG: Packet type 2 (Access-Accept) received
2025-09-19 13:54:49 DEBUG: Bad RADIUS response from 1.2.3.4; error: Response authenticator in received packet did not match expected value
Error: LibreNMS\Exceptions\AuthenticationException thrown!Invalid credentials

Affected Radius users are working properly with all other network equipment. All affected users appear to have 8 characters in their usernames.

./validate.php

Component Version
LibreNMS 25.9.1 (2025-09-17T18:23:00+02:00)
DB Schema 2025_06_30_080844_add_ipv4_network_index_to_ipv4_addresses_table (354)
PHP 8.2.28
Python 3.9.21
Database MariaDB 10.5.27-MariaDB
RRDTool 1.7.2
SNMP 5.9.1
===========================================

[OK] Composer Version: 2.8.11
[OK] Dependencies up-to-date.
[OK] Database Connected
[OK] Database Schema is current
[OK] SQL Server meets minimum requirements
[OK] lower_case_table_names is enabled
[OK] MySQL engine is optimal
[OK] Database and column collations are correct
[OK] Database schema correct
[OK] MySQL and PHP time match
[OK] Active pollers found
[OK] Dispatcher Service not detected
[OK] Locks are functional
[OK] Python poller wrapper is polling
[OK] Redis is unavailable
[WARN] IPv6 is disabled on your server, you will not be able to add IPv6 devices.
[OK] rrdtool version ok
[OK] Connected to rrdcached

Could you help me ?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.