Raspberry PI - Temperature, Voltage , Freq

I have done everything according to documentation but I still do not see the value in the section overview : Temperature, Voltage , Freq.


## Output from raspberry.sh
root@raspberrypi:/opt/librenms# /opt/raspberry.sh

## Edited by visudo :
root@raspberrypi:/opt/librenms# cat /etc/sudoers |grep raspberry
snmp ALL=(ALL) NOPASSWD: /opt/raspberry.sh, /usr/bin/vcgencmd*

## Also, I do not have a choice “RASPBERRY” in applications


Any ideas?



You are not alone, I did a fresh install of librenms last week, added a raspberry pi according to the documentation and I too have the same result. I only see the codec graphs.

This is due to raspberry’s SNMP not reporting those values.
You can add the unix-agent and feed them from that via munin-plugins for examples.

Or tell Raspbian & co to integrate vcgencmd call in their sensor output

SNMP reporting those vlaues:

No, it really is properly reporting the values. We’re all running the regular SNMP daemon with the SNMP Extend script for the Raspberry Pi set as an extension. It already deals with the vcgencmd calls and properly forwards those when requested via snmpwalk (what @mirino75 posted) and snmpget (what I’m posting now). I can confirm that the temperature and codec states are working on my own installation, but not voltages and frequencies. When I put the discovery script in debug mode, you can see that it properly reports two voltages, but that doesn’t cause the voltage sensors to be added:

I’ve been digging further, and it turns out that pull #5114 was responsible for the sudden inability to detect the other sensors. When I revert the modifcations from this commit to their previous state, I’m suddenly able to get the missing sensors to be finally detected after another discovery script run:

MWEN, thank you very much. You are solved my problem.

I am having the same issue. I just can’t figure out what the solution is here…

Do I need to revert changes made in the core files? Can someone shine some light on this?

I am now seeing codecs for my raspberry, but no other sensors.

Anyone try running this on Arch Linux? I have Arch on my Raspberry Pis but it’s missing vcgencmd?

Mine was on a different location (OSMC):

Maybe that helps…

I still only have the codecs visible, other sensors don’t show up anywhere… :frowning:

Hi @Jo0Lz seems like I can manually run the rasberry.sh script and it now shows values. I changed the in the rasberry.sh script
and this in the visudo
snmp ALL=(ALL) NOPASSWD: /etc/snmp/raspberry.sh, /opt/vc/bin/vcgencmd*
but doesn’t seem to work still.
I tried the same thing on my OSMC box and still nothing. Did I miss something?

Well, I’m having the same issue. I can see the values when I run the script, and I have some information about the codecs, but LibreNMS doesn’t show it. A few posts back, someone reverted to some older commit of the github, and that seemed to do the trick. I’m just hoping someone notices what’s wrong and fixes it so it will work as intended. (it doesn’t atm.)

Btw, I do see the values when I run the poller, so it does return the values through SNMP, LibreNMS just doesn’t process it. (Like the guys a few posts back pointed out)

We need to see the output of ./poller.php -h HOSTNAME -d -r -f -m unix-agent,applications


Connection to UNIX agent failed on port .

You need to fix that first.

I get the same error when I run that command… How would we go about fixing that? :confused:

 Uptime seconds: 594616
RRD[update /opt/librenms/rrd/ N:594616]
[RRD Disabled]Uptime: 6 days, 21h 10m 16s
SQL[SELECT `lat`,`lng` FROM `locations` WHERE `location`='Livingroom next to TV.' LIMIT 1]
Google geocode engine being used
Bad lat / lng received
Modules status: Global+ OS  Device
#### Load poller module unix-agent ####
LibreNMS UNIX Agent: SQL[SELECT attrib_value FROM devices_attribs WHERE `device_id` = '4' AND `attrib_type` = 'override_Unixagent_port' ]
Connection to UNIX agent failed on port .

Well, I’ve tried to follow this guide: http://docs.librenms.org/Extensions/Agent-Setup/ to try and resolve the issue with the “Connection to UNIX agent failed on port.”

I’ve checked the Raspberry PI, it’s not running a firewall, so connection to a port shouldn’t be an issue. How do I go about resolving that issue? According to the folks a few posts back, everything will work when we change the affected php file to another commit. I think I’ll try that, this is so painfully unclear, I’ve had this running up in Cacti in several minutes :frowning:

Well, guess I did something wrong. Just retraced every step I did in order to add the PI to LibreNMS.
I’m now getting results of the poller.php, however I still do not see the temperature being graphed or reported. (or anything other than the codecs and their state…)

Results of the poller.php command: ./poller.php -h HOSTNAME -d -r -f -m unix-agent,applications

Maybe I should refresh in a few minutes :smiley:

Sorry I told you wrong, pi stuff is in sensors so: ./poller.php -h HOSTNAME -r -f -d -m sensors but yes. after new graphs are created it can take 15 minutes.

Oh… :confused: well, I was excited the applications thing is finally returning results, and I can see a lot of graphs, but I really just want to graph the CPU temperature of the PI… That’s why I set it all up, other devices report back network data and such, and that is enough, I just wanted to see the temperature in a graph…

I’m at a loss. I created the script and it runs fine, I can see the results when running the script. I can snmpwalk and get the data I need, it just isn’t being graphed or picked up by the LibreNMS.
The result of the sensor thing is far less interesting, I guess something is still not working…