RRDTool not working

RRDTool 1.4.8 is not working and not showing graphs.

I was attempting to update rrdtool to 1.5.6 from a package and now it isn’t working at all. I removed all other packages with no luck. I reinstalled RRDtool 1.4.8 and still no luck. This is what my ./validate.php is showing.

[[email protected] librenms]# ./validate.php
/usr/bin/rrdtool: symbol lookup error: /lib64/libharfbuzz.so.0: undefined symbol: g_bytes_unref

Component Version
LibreNMS 1.43-138-gdd39a1a
DB Schema 268
PHP 7.2.10
MySQL 5.5.60-MariaDB
RRDTool
SNMP NET-SNMP 5.7.2

====================================

[OK] Composer Version: 1.7.2
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct

Everything else works fine, I can still add and poll devices and my web interface is fine.

your rrdtool is broken, you’ll need to fix that.

Try running /usr/bin/rrdtool to see.

Running /usr/bin/rrdtool provides the same error message. “/usr/bin/rrdtool: symbol lookup error: /lib64/libharfbuzz.so.0: undefined symbol: g_bytes_unref”

You need the libharfbuzz that matches your version of rrdtool.

I don’t think it matches libharfbuzz which is causing the issues. I think it used to be /libr64/ld-linux.

It is looking in the library /lib64/libharfbuzz.so.0 for the symbol g_bytes_unref, which is not there. you have an OS-level problem.

I copied the database over to a new build of LibreNMS and I’m still getting the blank section in RRDTool after running ./validate.php. With a new error >>> sh: /usr/share/rrdtool: Is a directory

You have set the rrdtool binary location to an incorrect value. Go to settings and set it to the correct value, probably /usr/bin/rrdtool

I’m using CentOS 7. Can you be more specific as to what settings I need to change and how?

You can set it in /settings/sub=external/ of the webui.

Type whereis rrdtool in your shell to find the location

thanks! that resolved it. Thanks all.