Setting snmp_bulk to false seems to have no effect

Since pull #13098 was merged on 9/1 changing nobulk → snmp_bulk, cyberpower and eltek devices on my campus are failing to poll or discover. Looking at the cli, I see lnms is using snmpbulkwalk for these hosts though their definition files have snmp_bulk = false.

Likewise, the config overrides also seem to have no effect:

$config['os']['cyberpower']['snmp_bulk'] = false;
$config['os']['eltek']['snmp_bulk'] = false;

Is anyone else seeing this behavior?


validate.php Output:


Seems like you have bigger problems, none of your MIBs are resolving and your database connection keeps failing.

D’oh… ya, I should have fully vetted the resolution of that db issue before pulling debug output. facepalm I rebooted a couple times to see if it would clear up the problem, but that lead to an index corruption issue (I think related to the eltek device getting stuck?) that I’ve cleaned up and things have been running cleanly since.

I took a new discovery here:

Despite any mib resolution issues, os detection is still working OK but even with the default cyberpower os definition file setting snmp_bulk set to false, my system is still using snmpbulkwalk sys binaries for polling and discovery. I’m walking through code to see if I can find out why, but haven’t found anything as of yet.

I think this is the cause:

Looks like includes/ merged still using ‘snmp_walk’ instead of ‘snmp_bulk’

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.