[Solved] Installation problem - webinstall mysql access denied

Using Ubuntu 18.04 installed as a guestOS on VMWARE ESXI.

I’ve followed the guide supplied at https://docs.librenms.org/#Installation/Installation-Ubuntu-1604-Apache/ through CTRL+C/CTRL+V regarding the commands in the guide, changing parameters where suitable ofc.

PHP 7.0 cannot be installed however, but rather 7.3 which is the latest version when using the package repositories which comes with the Ubuntu installation, this is a problem since php-7.3-mcrypt does not exist since it seems to be deprecated.

So I had to add a repository which holds the php 7.0 packages. The repository I’m using is:
sudo add-apt-repository ppa:ondrej/php

Additionally some php7.2 packages remain which causes conflicts while running composer to install LibreNMS, these are removed using the following commands:
sudo apt remove php7.2-cli php7.2-common php7.2-json php7.2-opcache php7.2-readline
sudo dpkg --purge php7.2-cli php7.2-common php7.2-json php7.2-opcache php7.2-readline

After doing this the composer command can be run and completes (although with an error message):
sudo composer create-project --no-dev --keep-vcs librenms/librenms librenms dev-master

The error message I receive when running the composer command is:
Error: Missing dependencies! Run the following command to fix:

./scripts/composer_wrapper.php install --no-dev

However when I run the command supplied I get this response:

Loading composer repositories with package information
Installing dependencies from lock file
Nothing to install or update
Generating autoload files
php artisan optimize
Generating optimized class loader
The compiled services file has been removed.

After following through with the remaining steps of the installation and get to the webinstaller, when I get to step 2/6 I get the error message:
Access denied for user ‘librenms’@‘localhost’ (using password: YES)

I’ve tried using Chrome & IE.

I’ve tried to:

  1. Remove user & DB and adding again.
  2. Removing and reinstalling mysql/mariadb.
  3. Tried adding another user in addition to DB:
    CREATE DATABASE librenms2 CHARACTER SET utf8 COLLATE utf8_unicode_ci;
    CREATE USER ‘librenms2’@‘localhost’ IDENTIFIED BY ‘librenms2’;
    GRANT ALL PRIVILEGES ON librenms2.* TO ‘librenms2’@‘localhost’;

restarting mysql afterwards:
sudo systemctl restart mysql

  1. Removing the /opt/librenms via = sudo rm -rf /opt/librenms & running the composer command again. Ofc running the commands below after doing so:
    sudo chown -R librenms:librenms /opt/librenms
    sudo setfacl -d -m g::rwx /opt/librenms/rrd /opt/librenms/logs /opt/librenms/bootstrap/cache/ /opt/librenms/storage/
    sudo setfacl -R -m g::rwx /opt/librenms/rrd /opt/librenms/logs /opt/librenms/bootstrap/cache/ /opt/librenms/storage/

As I said, I’ve CTRL+C/CTRL+V the input supplied in the installation guide, and am now at a loss as to what to do. I’m


Component Version
LibreNMS 1.41-76-g7f16e586a
DB Schema ?
PHP 7.0.31-1+ubuntu18.04.1+deb.sury.org+1
RRDTool 1.7.0


[FAIL] config.php does not exist, please copy config.php.default to config.php

It appears that I missed the fact that:
CREATE DATABASE librenms CHARACTER SET utf8 COLLATE utf8_unicode_ci;

Cannot accept nordic characters when:
CREATE USER ‘librenms’@‘localhost’ IDENTIFIED BY ‘password’;

When I created a password which did not include the letter ä, the webinstall proceeded.

Talk about simple but infuriating…