SSL only applying to Dashboard

Hello
I tried to add SSL to the libreNMS but afterword comes with
Not Found

The requested URL /notifications/archive/ was not found on this server.
But I can login to Dashboard after no sub link working with SSL.
Also, PHP validation gave me

====================================
Component | Version
--------- | -------
LibreNMS | 1.32-71-g1f7274d37
DB Schema | 211
PHP | 7.0.19-1
MySQL | 10.1.23-MariaDB-9+deb9u1
RRDTool | 1.6.0
SNMP | NET-SNMP 5.7.3
====================================

[OK] Database connection successful
[FAIL] Database: incorrect column (notifications/datetime)
[FAIL] Database: incorrect column (users/created_at)
[FAIL] We have detected that your database schema may be wrong, please report the following to us on IRC o r the community site (https://t.libren.ms/5gscd):
ALTER TABLE notifications CHANGE datetime datetime timestamp NOT NULL DEFAULT ‘1970-01-02 00 :00:00’;
ALTER TABLE users CHANGE created_at created_at timestamp NOT NULL DEFAULT '1970-01-02 00:00:

Anyone able to help ?
Many thanks in advance.
ncm

What are you trying to enable SSL on? What is OS and this Apache or Nginx?

1 Like

Hello
I’m using raspberry pi (RASPBIAN STRETCH LITE), so its apache 2 and php7, I am able to setup the LibreNMS its running fine, To access remotely I would like to enable the SSL on LibreNMS

Did you set base_url (with http)? Either unset that in your config.php or change it to https/

1 Like

Thanks
I set the config.php to

$config[‘base_url’] = “https://10.10.10.17/”;
but still get the same error

what dose your config in/etc/httpd/conf.d/librenms.conf look like

1 Like

I found 2 files name with librenms.conf in different locations both look like following
/etc/apache2/sites-available/librenms.conf and following
cat /etc/apache2/sites-enabled/librenms.conf
<VirtualHost *:80>
DocumentRoot /opt/librenms/html/
#Redirect “/” "https://10.10.10.17/"
ServerName monitor
CustomLog /opt/librenms/logs/access_log combined
ErrorLog /opt/librenms/logs/error_log
AllowEncodedSlashes NoDecode

    <Directory "/opt/librenms/html/">
            Require all granted
            AllowOverride All
            Options FollowSymLinks MultiViews
    </Directory>

I’ve stopped the redirection as https not working for all pages
thanks

im not sure but here what I have conf for

(obviously changing librenms.example.com to your actual domain name):

        <VirtualHost *:443>
        SSLEngine on
        SSLCertificateFile /etc/pki/tls/certs/ca.crt
        SSLCertificateKeyFile /etc/pki/tls/private/ca.key
         <Directory "/opt/librenms/html/">
        DocumentRoot /opt/librenms/html/
         AllowOverride All
        AllowEncodedSlashes NoDecode
        Require all granted
        Options FollowSymLinks MultiViews
  `      </Directory>`
        DocumentRoot /opt/librenms/html/
        ServerName librenms.example.com
        CustomLog /opt/librenms/logs/access_log combined
         ErrorLog /opt/librenms/logs/error_log
1 Like

thanks
I followed the following and seems to be working fine :slight_smile:

1 Like