SYSLOG not working 1.58

Hi,
I have setup new LibreNMS following the Document on the site. I have enabled Syslog with SYSLOG-NG. But I am not getting any logs in the Web interface. or even the database is empty.

Some useful information is below.

`[[email protected] librenms]# ./validate.php

Component Version
LibreNMS 1.58
DB Schema 2019_10_03_211702_serialize_config (147)
PHP 7.2.24
MySQL 5.5.64-MariaDB
RRDTool 1.4.8
SNMP NET-SNMP 5.7.2

====================================

[OK] Composer Version: 1.9.1
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct
[[email protected] librenms]#
`
Here is the syslog-ng.conf output

`# Destinations
########################
destination d_librenms {
program("/opt/librenms/syslog.php" template ("$HOST||$FACILITY||$PRIORITY||$LEVEL||$TAG||$R_YEAR-$R_MONTH-$R_DAY $R_HOUR:$R_MIN:$R_SEC||$MSG||$PROGRAM\n") temp$
};

filter f_kernel { facility(kern); };
filter f_default { level(info…emerg) and
not (facility(mail)
or facility(authpriv)
or facility(cron)); };
filter f_auth { facility(authpriv); };
filter f_mail { facility(mail); };
filter f_emergency { level(emerg); };
filter f_news { facility(uucp) or
(facility(news)
and level(crit…emerg)); };
filter f_boot { facility(local7); };
filter f_cron { facility(cron); };

########################

Log paths

########################
log {
source(s_net);
source(s_sys);
destination(d_librenms);
};

Source additional configuration files (.conf extension only)

@include “/etc/syslog-ng/conf.d/*.conf”

vim:ft=syslog-ng:ai:si:ts=4:sw=4:et:

`

SE linux is disabled.

[[email protected] librenms]# sestatus
SELinux status: disabled

TCPDump shows that syslogs are hitting the NMS.

moreover,
[[email protected] librenms]# syslog-ng-ctl stats
SourceName;SourceId;SourceInstance;State;Type;Number
dst.program;d_librenms#0;/opt/librenms/syslog.php;a;dropped;0
dst.program;d_librenms#0;/opt/librenms/syslog.php;a;processed;135
dst.program;d_librenms#0;/opt/librenms/syslog.php;a;stored;0
destination;d_librenms;;a;processed;135
src.internal;s_sys#2;;a;processed;2
src.internal;s_sys#2;;a;stamp;1574673239
center;;received;a;processed;2
center;;queued;a;processed;135
src.none;;;a;processed;0
src.none;;;a;stamp;0
global;payload_reallocs;;a;processed;0
global;sdata_updates;;a;processed;0
global;msg_clones;;a;processed;0
source;s_sys;;a;processed;2
source;s_net;;a;processed;0
[[email protected] librenms]#

However still no logs on the GUI

Can somebody help me.

The /opt/librenms/syslog.php is default.

Thanks.