Version in WebUI does not match Validate

I updated PHP from 8.3 to 8.5 on this server after completing another one without any issues and following the same steps. Now the webui shows 26.7.0 and validate shows 26.8.0 from today. The web validate does have the error below:

FAIL: Failed to fetch version from local git: fatal: detected dubious ownership in repository at ‘/opt/librenms’ To add an exception for this directory, call: git config --global --add safe.directory /opt/librenms
WARN: Your local git branch is not master, this will prevent automatic updates.

I tried the suggested command as well as “git checkout master” and it tells me I am already on “master” and your branch is up to date with ‘origin/master’.

Any help with this issue would be greatly appreciated.

Version 26.7.0 - Tue Jul 21 2026 00:19:03 GMT-0400
Database Schema 2019_12_14_000001_create_personal_access_tokens_table (396)
Web Server nginx/1.24.0
PHP 8.5.9
Python 3.12.3
Database MariaDB 10.11.14-MariaDB-0ubuntu0.24.04.1
Laravel 12.64.0
RRDtool 1.7.2
Net-SNMP 5.9.4.pre2

===========================================

Component Version
LibreNMS 26.8.0-dev.97+a74147134 (2026-08-11T09:37:21-04:00)
DB Schema 2019_12_14_000001_create_personal_access_tokens_table (396)
PHP 8.5.9
Python 3.12.3
Database MariaDB 10.11.14-MariaDB-0ubuntu0.24.04.1
RRDTool 1.7.2
SNMP 5.9.4.pre2
===========================================

[OK] Composer Version: 2.10.2
[OK] Dependencies up-to-date.
[OK] Database Connected
[OK] Database Schema is current
[OK] SQL Server meets minimum requirements
[OK] lower_case_table_names is enabled
[OK] MySQL engine is optimal
[OK] Database and column collations are correct
[OK] Database schema correct
[OK] MySQL and PHP time match
[OK] Active pollers found
[OK] Dispatcher Service not detected
[OK] Locks are functional
[OK] Python poller wrapper is polling
[OK] Redis is unavailable
[OK] rrd_dir is writable
[OK] rrdtool version ok

your web server/php-fpm cannot access the git directory this causes checks to fail giving you incorrect information. Try running the listed command as the web server user.

I ran it as root and librenms without any luck.

root won’t help as nothing from LibreNMS should ever be run as root.

what user are your web server processes running as? you can check with ps aux

Nginx is running as root and worker processes as www-data…

It is www-data then.

Not sure what happened, but it looks like it fixed itself overnight (daily update?). The versions match and I no longer have the validate error. Thank you for your help troubleshooting this issue.