Weathermap errors

No, what version of librenms on the one that working with the graphs

Please see attached image

The intresting thing is , if I move the png ,html and conf file from old server to new server
In a new server the floating graph is working for this specific graph

I fixed the floating graph, there is a value on the Map properties , called default width, set it to 4, and it should give the floating graph

Awesome!! :slightly_smiling_face:

I will try it on mine too -

If you can truly make this happen more than once, please report it as a bug here:

(this sounds like it it really isn’t what fixed your problem - HTMLSTYLE overlib is the solution)

You can also search for the WMWARN error codes and in most cases get an idea of the solution - that’s why they were added :slight_smile:


I am using ./IPaddress/ as the source in my conf files and I am getting errors that the file does not exist.

conf line
INFOURL /graphs/type=port_bits/id=3363/
OVERLIBGRAPH /graph.php?height=100&width=512&id=3363&type=port_bits&legend=no

The file is located in weathermap/rrd
-rw-rw-r-- 1 librenms librenms 1849688 Mar 26 15:41 port-id3363.rrd

My rrdtool is located in /usr/bin/

My error is
Target ./ doesn’t exist. Is it a file? [WMRRD06]

Any ideas??

[[email protected] Weathermap]# ./weathermap.php --config configs/cg.conf --output output/cg.png --htmloutput output/cg.html
PHP Notice: Undefined property: WeatherMap::$basehref in /opt/librenms/html/plugins/Weathermap/weathermap.php on line 287

It tells you have an error on line 287.

Hit same issue. Fixed it by adding to the .conf file the following:
In the map properties it had been set too, but only duplicating it inside the config file helped.
Hope it might be helpful

This helped me.

./weathermap.php --config configs/prod_mpls.conf --output output/mymap.png --htmloutput output/mymap.html --base-href /opt/librenms/html/plugins/Weathermap/

notice I put in the --base-href /opt/librenms/html/plugins/Weathermap/

That got rid of my line 287 error.

Hi all. I’m a newbie. I have the same error but I don’t know how to fix it. I’m using Weathermapper to auto-create map. So now the router could be created. But don’t have any link.