Web GUI Links Adding 'http:' Within the URL Causing 404 Errors

Running the VM version of LibreNMS, I’ve noticed links within the GUI are adding ‘http:’ within the link URL, which is causing 404 errors when clicking the link.

For example, clicking a link in my alert log points to: http://x.x.x.x/**http:**/device/device=3/tab=alerts/section=alert-log/ … resulting in a 404 error. If I manually remove the second ‘http:’ within the URL, the page loads normally.

1 Like

Hi - I have the same problem. I installed a fresh virtual machine yesterday and got confused over this.
Found one link to edit /etc/nginx/conf.d/librenms.conf but I can’t se what to change for this error.

Help wanted!

in config.php i think you have to uncomment base_url line so it is base_url set to /

1 Like

Most often this is caused by a bad server_name setting on your web server.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.